iPhone Edge In Lebanon

Finally managed to connect my iPhone to mtctouch edge network, and its working brilliantly.

This can also be applied to alfa,  just ask for it in the comments and i will upload it!

Its as easy as 1 , 2 , 3 …

Advertisements

94 thoughts on “iPhone Edge In Lebanon

  1. Pingback: Alfa Edge File Hack « ZuZ's Blog

  2. Hi Zuz,

    I’ve been trolling through the internet for ages trying to find a solution for my problem..
    Here’s the situation:

    I have an iPhone 3G with the 2.2.1 firmware (unlocked with yellowSn0w) and an MTC Touch postpaid line; everything was working fine until I added the GPRS/EDGE package for my line. Reception started dropping suddenly, until I would get to a point where I got the “No Service” indication and I would have to restart my phone (turning airplane mode on/off did not fix this)

    I upgraded to 3.0 FW and unlocked using ultrasn0w hoping this would fix my problem, but it didnt! I also tried using my friend’s iPhone instead for a couple of days, and im encountering the same issue – it’s drving me crazy! Anyone else encountering this? Zuz, what exactly are u using???

    Reply
  3. Was it an iPhone 2G or 3G ? What did u do to fix the issue?

    What’s driving me insane about this is that it’s happening on more than one phone (iPhone.) Grrr… Now I’m trying to restore the iPhone to 3.0 FW on a different computer than the one I normally use – I’ve also requested a replacement sim card from MTC. I’m hoping one of htem will help.

    In the meantime, I’m reading the forum you’ve posted.

    I’m also trying to get the new 3Gs from the USA.. Very soon 🙂

    Reply
  4. LOL I just realized that you are the initial posted at the forum.

    But as I said, I don’t believe it’s a hardware problem since it’s not restricted to just 1 iPhone.

    Are u using MTC or Alfa ?

    Reply
  5. yes most probably ur problem is not hardware related! hopefully they will issue u a new sim card!

    another idea would be to put ur sim in another phone and try to delete the data stored on the sim (GPRS/EDGE/MMS).. try a nokia phone!

    if that is what is giving you the no service issue, then this must help.!

    its certainly worth the shot!

    as for the iphone 3gs!! i envy you! i am still on the 2g! i got it on october 2007 so its almost 2 years old!

    how much does the 3gs cost and can you get it at the $199 price?

    Reply
  6. Nope – I’ll be paying premium price for the 3Gs (I have a 3G right now which I’ll be selling to my nephew) and getting the 3Gs for $650 (the 16GB version) from eBay.

    I wasn’t aware that GPRS/EDGE settings get stored on the sim card! That’s definitely one thing to look into.

    I’m also going to install BigBoss toggles and try to disable EDGE and see if it will help.

    Cheers,

    Reply
  7. umm for me 3gs isnt worth that money!
    i am waiting for a re-design! maybe next july apple will introduce a new design!

    nevertheless the 3g and/or the 3gs wont survive the nasty drops my 2g suffers on a daily basis! 😦

    Reply
  8. Haha you’re totally right – I remember the 2G.. It was rock-solid!! (I sold mine in January to get the 3G!)

    I’ve just tried restoring the iPhone on a different computer, jailbreaking, and installing the latest unltraSn0w unlock.. I got my fingers crossed 😉

    Reply
  9. Lak akhhh ya zuz…

    didnt work either.. It went allright all day long, then just half an hour ago, i left the house, and it started acting up.. no signal, then signal, on and off for about 10 min.. then finally it got stuck on “No Service”

    I think the baseband crashed or something cos even when i put it in and out of airplane mode, it still doesnt recognize it. I even tried inserting another sim card (active line)without restarting the phone, and it wont connect..

    Reply
  10. Hey zuz, I am using iPhone 3g 8gb running 3.0 unlocked with ultrasn0w. I have mtctouch with wap. What excactly should i do to enable the wap feature on my iPhone? Can you pleaze email me the instructions on abazarbachi@yahoo.com? Thanks

    Reply
    • U can find the files u want in the box on the right side of this blog!
      get the file and send it to urself my email and check it from your iphone

      Reply
    • i’ll look into it as soon as i get home, am at work atm and i have to be on my macbook to fix it!

      it seems that alfa has either changed the ips or blocked it!

      gimme some time and i will get back to you!

      Update: Try to get the new file i just uploaded, the new name is alfawapUpdated.mobileconfig..
      try it please and let me know if it works!

      Reply
      • hey,
        I downloaded the new file, sent it as an email to myself w tried to get it on the iPhone. I got a screen saying:
        invalid profile
        profile format not recognized

        so I couldn’t install it quite yet.

      • still not working… u know the little turning star next to the little E goes very slowly bass it doesn’t give u the usual: server couldn’t be found or pdp thing cannot be authenticated…
        I only get a screen after a while saying:

        Cannot Open Page:
        Safari could not pen the page bec the server stopped responding.

      • yeah, im trying to use them as we speak… the thing next to the E spins forever very slowly and nothing updates.

  11. Guys…any information about the no service issue after installing wap?
    I noticed something…
    My line was deactivated because I crossed the bill limit which is 250$
    during the 3 days of deactivation i didn’t face the no service problem in which I have to restart my iPhone…
    I have a 32Gb 3GS original unlock
    any ideas?
    It’s really annoying…it happens only when drive for long distance…but inside Beirut it never happened…wish to be solved soon…

    Reply
    • Both MTC and Alfa have a problem with their network architecture, in a way that whenever you are using the wap service, you are out of reach. Which means that if anyone tried to call you whenever you are using wap, they will get the “Not Available” signal.

      My guess is that some basebands are not compatible with this “feature” and thus giving the No Service.

      This explains that when your line was deactivated, your wap service was unavailable and your line functioned normally!

      My suggestion for you is to try to disable edge whenever you’re not using it!

      Reply
    • how did u get it to activate?
      I got 1 from Australia (16 gb, 3gs) but it wouldn’t activate so i sent it back. Redsn0w and all those stuff wouldn’t work either..

      Reply
      • Well…I got it unlocked from Jordan on any carrier…no need for jailbreak or redsnow…or any kind of snows 🙂
        What is the firmware installed on your 3GS was it 3.0 or 3.1?

      • mine was also factory unlocked (plug it in iTunes, happy iPhone has been unlocked screen comes)…
        the firmware was 3.0.1. I updated it to 3.1 before sending it back.

  12. hi Zuz,
    is mtc wap working right on ur iphone ? safari? maps ? weather?

    and did u try mtc wap on a prepaid card?
    coz i’ve been told that the iphone will use all the account in less than one day even if u don’t use anything.
    regards

    Reply
    • hi rosa!
      no i havent tried it on a prepaid card!

      yes i will have to agree with those who said that it will use all your data in 1 day!

      i will post a new topic to discuss this so check it out 🙂

      Reply
      • if it does , then it’s not worth it to have wap on iphone. especially that mtc doesn’t allow to recharge ur wap service before the month is over.
        so who will be interested in using all his data in one day and stay not connected for the rest of the month?

        and did mtc block safari ports like alfa (like Mak said)

        thx for ur earlier reply 😉

      • Safari works gr8 with mtc prepaid line…
        When I had my prepaid line I used the 20 MB in 15 to 20 days…I used to browse mobile site like igoogle and facebook mobile…and bitesms for cheaper SMS 🙂
        u have to know that the data on edge are compact data…it means the 20 mg are 40 mg when using normal computers 🙂

      • I guess mobile mail is sucking all the bandwidth :p

        rosa you can always try it for 1 month and see how your quota holds !
        if they expired shortly then dont renew it!
        after all its all a matter of preference and what you actually want!

        thank you Mak for confirming that 🙂

      • Ur most than welcome 🙂
        by the way I was using google mobile application…it’s a normal web browsing…so it doesn’t suck anything more than it should suck 😀 😛

  13. alfa guys try to get another browser from the app store or cydia and try browsing thru it!
    i am guessing that if not port blocking it may be blocking according to the meta data sent by the web browser and in this case “Safari”

    Reply
    • you can find all files on the right banner! (its called mtcwap.mobileconfig)

      download the file to your pc and email it to yourself and then check the email using your iphone mail application.

      🙂

      Reply
  14. hey i have an iphone 3g ,version:3.1.2 and i’m soo tierd i wanna know how to enable wap connection on it using alfa line ? plz help :S

    Reply
  15. Hey guys, I downloaded the mtc config file installed it and have been a happy wap user for almost a month now, one problem though, it seems to only work for safari, all other applications can’t connect, I was wondering if the problem is that the apps I’m using are trying connect to some closed port on mtc’s servers or is there a way to fix this?

    thanks

    Reply
    • sadly there is NO way to fix this,
      mtc has blocked all the ports on wap except for the port 8080 which is just basic http

      if u upgraded to gprs, then u will get most ports open, but will cost u more and with a limit on ur bandwidth!

      Reply
  16. hey man, i have postpaid mtc.. and i have the $5 wap service activated.. before i downloaded ur file, i used to have “E” showing on the top but when trying to connect it fails to.. after downloading and installing the file.. the “E” disappeared completely and connection not working either.
    thanks,

    Reply
  17. hey zuz i have a 3g iphone, with the software 3.1.2 and it is unlocked and i use alfa on it. today i connected to the edge network here in lebanon but i need access and i dont know how to do it, pleaseeee help!!!
    occasionally the “e” turns to an “o” but i still dont have access i really have no idea how it registered it but i want interent pleaseeeeee helpp!
    u reply to my email right?

    Reply
    • the o and e just indicate what type of data network u are connected to..

      it makes no difference whatsoever..

      to get wap working on ur iphone, u need to call alfa and ask for the wap service to be enabled, don’t tell them u have an iphone coz they won’t activate it.. and then u have to download the alfawap mobileconfig settings from the right banner , and email it to urself.. and open that email using ur iphone..

      goodluck

      Reply
  18. Hi Zuz. I have a 3GS – 32GB which i bought from Belgium… so it DOESNT need any jailbreak or unlock because it is already apple unlocked from origin! (i think that Belgium and Italy are the only 2 countries in Europe selling the iPhone already apple unlocked).
    Running software is 3.1.3 with a post paid MTC Touch line
    Now everything was working fine until I added the GPRS/EDGE package for my line. As for some others, reception also started dropping suddenly, until I would get to a point where I get the “No Service” indication and I would have to restart my phone (turning airplane mode on/off did not fix this).
    Do you have any idea how to solve it? If you can help, please send me the info on:
    siso_@hotmail.com

    thanks in advance.

    Reply
    • the problem is with mtc and wap..

      the iphone was NOT made to work with wap, and this hack is just a third party solution for wap and cheap internet access for the iphone..

      there is currently no fix for this, as i don’t have a 3GS to test on..

      u have to try and live with it, or u could get gprs from mtc, but that will costs u 5 times more for a limited connection

      Reply
    • Download the mtcwap mobileconfig file from the shared files on the right banner and email these settings to ur self, and open the email on the iphone

      Reply
  19. Hey,
    I’ve been using wap for over a month now and after my 1 month subscription ended, the “E” symbol is still there and my iphone gets no service probably 3 times a day ad requires a restart. can u help me? i tried calling mtc touch but they said they cant do anything. can u teach me how to delete the data stored in the sim?
    Thank you.

    Reply
      • The problem is that i already did that and tried it so many times but still no luck :s
        hope you can help me fix this annoying issue.
        Thank you

      • The problem is that i already did that and tried it so many times but still no luck :s
        hope you can help me fix this annoying issue.
        Thank you.

  20. I had the same problem and got it solved by going to MTC and asking a new SIM card. It cost me 5$, but now at least i dont get the No Service thing anymore! The problem is that the GPRS settings stay stored on the SIM card even if you remove all the settings from the iPhone. So the only solution is to replace the SIM card with a new one.

    Reply
  21. Hey Zuz,

    So I had your configuration working perfectly on my phone when i had the Iphone 3G OS 3.0.1. I have and alfa line and the wap was working perfectly … But I decided to update my Iphone to the latest version since i was encountering some speed problems with last version… Now i have the the custom 3.1.3 version( by pwnage tool) jailbreaked and unlocked with blacksn0w RC2 Final from Cydia or Rock and not Blackra1n and everything is working flawlessly except one problem … next to the carrier wich in my case is alfa i can’t find neither the GPRS icon ( wish is the blue round icon ) neither the EDGE icon ( wish is E )… i reinstalled ur configuration for the alfa wap and did everything i should do so that everything will work fine ( UAFAKER, and the modification in the ua facker file in winscp…. anw neither of the icons is showing and i have no internet connection through the data plan or wap … but the wireless is working fine … i tried to restore the ISPW again thinking that i have done a possible error in the process but still i have encountered the same problem :S…
    I searched over the internet of find a solution for this problem but with no luck . if you can please help me in anyway… i will be more than grateful.

    Thanks in advance ZUZ ur the best 🙂
    (big_boyaloush355@hotmail.com)

    Reply
  22. Hey zuz, I tried restoring to several other custom 3.1.3 and the same problem apeared , I also tried to downgrade to 3.1.2 but it ddnt work also 😦 … I really hate my iPhone without any Internet connection even if it was the crapy Alfa WAP ! Any other suggestions ?!

    Reply
  23. Hi Zuz,

    Thanks for the great site.

    Got 2 factory unlocked iphones that are not hacked.

    Will it work without hacking?

    If so please send me the Edge profile for both Alfa and MTC.

    Thanks!

    Reply
  24. hi Zuz,
    plz tell me how to unlock my iphone 3G on version 3.1.2 ,i upgrade and unlocked my iphone,but i cant call or send sms,my iphone isnt able to get any carier from lebanon why, tell me the solution
    my mail : karrar_m16@hotmail.com
    thanks

    Reply
  25. hey zuz,
    i have an iphone 3g updated to 3.0
    i just downloaded the whatsapp and i activated the WAP from alfa however safari and whatsapp dont use WAP
    i tried downloading from http://apt.rachini.com/ the .mobileconfig but the safari gave me a pdp failure or watever. The rachini website said i have to download it from my comp so i tried bas the alfa link is broken
    any help 😦 ?

    Reply
    • alfa, has blocked safari from working, and whatsapp doesnt work over wap, u need gprs..
      some reader posted a way of faking ur user agent.. search for it and use it.. it works!

      Reply
  26. Hey Zuz,
    I am running GPRS on MTC touch iphone 3G 3.1.2.
    I got some questions for you, if I chose to go to WAP (postpaid)
    Will I be able to run: Weather, Maps, WhatsApp, Safari, Gmail on Mail app (not through exchange account), Cydia and Installous?
    Thanks…

    Reply
  27. Hi, I have Iphone 4 running in lebanon after cutting the regular sim. Now I need to run the Mobile Internet service but MTC said that I cant run the service on Iphone cuz my line is Prepaid MTC Magic! is there any solution for this.Please help

    Also for those interested to buy brand new Iphone 4, i have two more for sale. Contact me on eliemetri@gmail.com

    Regards,

    Elie

    Reply
  28. guys im sorry but im an idiot at this stuff! i got a blackberry and an mtc prepaid number! i hear that whatsapp only works on wifi or a bb service. can i use wap to activate it? thx

    Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s